解决安装python3.7.4报错Can”t connect to HTTPS URL because the SSL module is not available

简述 从官网下载了Python3.7.4,直接编译安装后,使用pip3出现了报错信息: Can’t connect to HTTPS URL because the SSL module is not available 错误原因 在Python3.7之后的版本,依赖的openssl,必须要是1.1或者1.0.2之后的版本,或者安装了2.6.4之后的libressl。 image.png 而本地的openssl依然是1.0.1e的。 1 2 [root@localhost ~]# openssl version OpenSSL 1.0.1e-fips 11 Feb 2013 解决方法 上openssl官网下载1.0.2或者1.1之后的openssl包,编译安装。我选择的是1.0.2r。 1 2 3 4 5 6 [root@localhost ~]# wget http://www.openssl.org/source/openssl-1.0.2r.tar.gz [root@localhost ~]# tar zxvf openssl-1.0.2r.tar.gz [root@localhost ~]# ./config –prefix=/opt/openssl1.0.2r –openssldir=/opt/openssl1.0.2r/openssl no-zlib [root@localhost ~]# make …