flutter 使用MD5加密

1、在pubspec.yaml中引入crucpto,更新依赖

crypto: ^2.1.5
2、引入头文件

import ‘dart:convert’;
import ‘dart:typed_data’;
import ‘package:crypto/crypto.dart’;
3、使用md5加密

///使用md5加密
String generateMD5(String data) {
Uint8List content = new Utf8Encoder().convert(data);
Digest digest = md5.convert(content);
return digest.toString();
}
————————————————
版权声明:本文为CSDN博主「SkyCloud5+2」的原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/lqw200931116/article/details/123040516

Share