致命错误:Python.h:没有那个文件或目录

在使用pip安装scrapy时发现以下错误:原因是没有安装python 的dev包

 

查看python 的dev包。由于我的python3使用yum安装的包为python36u

查看对应的开发包:【查询后根据自己安装的python版本来选择】

yum search python3 | grep dev

 

安装:【查询后根据自己安装的python来选择安装 python-dev】

sudo yum install python36u-devel

 

最后安装scrapy:问题解决!

 

Share